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RELEASE NOTES

NI-DAQ  FOR PC COMPATIBLES VERSION 6.5
These notes contain information you must know before installing NI-DAQ 
for PC Compatibles, version 6.5. They explain how to install your 
NI-DAQ 6.5 driver software on Windows NT/98/95. They also contain 
instructions on how to install and use your electronic documentation set.

What Is Different about Version 6.5
Among the new features of NI-DAQ 6.5 are support for new hardware 
products, new NI-DAQ examples, the Measurement & Automation 
Explorer for configuring your devices, and a new NI-DAQ Setup program.

New Functions, Examples, and Newly Supported Hardware
For more details about new functions, examples, and newly supported 
hardware, refer to the NI-DAQ Readme file, which has a link to the 
National Instruments home page. Before installation, you can find the 
readme.htm file on your NI-DAQ 6.5 software CD. If you have already 
installed NI-DAQ, select Start»Programs»National Instruments 
DAQ»NI-DAQ Readme File to access this information.

Measurement & Automation Explorer
The Measurement & Automation Explorer is a new utility that is installed 
as a desktop icon during your NI-DAQ software installation. Click on the 
Measurement & Automation icon to configure your National Instruments 
software and hardware, to execute system diagnostics, to add new 
channels, virtual channels, and interfaces to your system, and to view the 
devices and instruments you have connected.

Measurement & Automation Explorer provides multiple views of your 
National Instruments resources. At the highest level, resources appear in 
three categories: Data Neighborhood, Devices and Interfaces, and 
Scales. 
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The Data Neighborhood is a repository of virtual channels. A virtual 
channel is a shortcut to a configured channel in your system. Virtual 
channels are beneficial because you can name them intuitively, such as 
“Thermocouple 1.” You configure the attributes of your local or remote 
hardware products through the Devices and Interfaces option. You use 
Scales to define custom scaling algorithms you can use to transform any of 
your data.

NI-DAQ Setup
You use NI-DAQ Setup to select the specific examples, documents, and 
support files you want to install for your hardware and application 
development environments (ADEs). NI-DAQ Setup is automatically 
launched when you reboot after installing your NI-DAQ software. If you 
need to install additional components later, select Start»Programs» 
National Instruments DAQ»NI-DAQ Setup.

NI-DAQ 6.5 Replaces VI Libraries and Online Help
If you are using LabVIEW version 4.x or higher, or BridgeVIEW 1.x or 
higher, NI-DAQ Setup will give you the option of updating DAQ-related 
components. If you choose this option, the following files will be replaced: 

• VI.LIB\UTILITY\error.llb (the error handler VIs in the 
Time and Dialog palette)

• HELP\lvdaq.hlp and HELP\findxmpl.hlp  (DAQ Online Help 
and Search Examples Help)

• All library files in VI.LIB\DAQ  (all VIs on the DAQ palettes, and all 
corresponding palettes in MENU\DEFAULT and MENU\DAQVIEW)

• All library files in VI.LIB\SOL  (the Solutions Gallery VIs)

• All library files in EXAMPLES\DAQ (all the DAQ Example VIs)

If you have saved VIs into any of these libraries, you should quit the 
installer, launch LabVIEW, copy any such VIs to another place, quit 
LabVIEW, and restart the installer.

Localized Resources Are Not Provided
The NI-DAQ 6.5 CD does not contain resources localized for Japanese, 
French, or German. When you run the installer, only English resources are 
installed. These localized resources will again be available in languages 
other than English in a future NI-DAQ release in 1999. We sincerely 
apologize for any inconvenience this causes our customers.

For those products that were supported in the previous version of NI-DAQ 
(version 6.1), we have included a CD of that version together with your 
NI-DAQ 6.5 CD. You may, if you wish, install NI-DAQ 6.1 instead of 
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NI-DAQ 6.5 and use those localized resources. If your kit contains only the 
NI-DAQ 6.5 CD, your product is too new to be supported in NI-DAQ 6.1. 

Note For users of localized LabVIEW: If you run the NI-DAQ Setup program on your 
version of LabVIEW, all the DAQ components will become English. If you prefer 
the localized version of the LabVIEW DAQ components, do not choose to upgrade 
LabVIEW DAQ components in the NI-DAQ 6.5 Setup program. If you prefer to 
have the NI-DAQ 6.5-specific enhancements, such as support for new products 
and improvements to the LabVIEW DAQ VIs, examples, and online help, please 
select to upgrade LabVIEW DAQ components in the NI-DAQ 6.5 Setup program, 
which will install the English LabVIEW DAQ components.

Installing NI-DAQ 6.5 
Most NI-DAQ software kits contain two CDs, one for NI-DAQ 6.5 and one 
for NI-DAQ 6.1. If your kit contains only the NI-DAQ 6.5 CD, your 
product is too new to be supported in NI-DAQ 6.1. If one of the following 
conditions applies, do not use NI-DAQ 6.5: 

• You want Mac OS support.

• You want Windows 3.1 support.

• You want localized resources (French, German, or Japanese). Refer to 
the previous section, Localized Resources Are Not Provided, for more 
details.

General Installation Steps
Because all system architectures are different, each one requires a different 
device configuration procedure. However, in most cases you follow the 
same general steps:

1. Install your application software (LabVIEW or LabWindows/CVI, for 
example).

2. Install your NI-DAQ driver software.

• To install NI-DAQ 6.5 on Windows NT/98/95, insert the NI-DAQ 
version 6.5 CD into your drive and select Install NI-DAQ .

• To install NI-DAQ 5.0 on Windows 3.1, insert the NI-DAQ 
version 6.1 CD into your drive and run setup.exe .

• To install NI-DAQ 6.0 on the Mac OS, insert the NI-DAQ 
version 6.1 CD into your drive and run NI-DAQ Installer .
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Note The NI-DAQ software that ships with your hardware is the latest version of 
NI-DAQ. In some cases, National Instruments application software will install an 
older version of the NI-DAQ driver software. In such cases, you should install the 
NI-DAQ software that shipped with your hardware after you have installed your 
application software. In all cases, install your NI-DAQ software prior to installing 
your DAQ hardware.

3. Install your data acquisition (DAQ) hardware device.

4. Reboot your computer. The NI-DAQ Setup program is automatically 
launched. Follow the prompts to install the appropriate support files, 
such as examples, online documents, and support files needed by your 
ADE.

a. Click on the device, module, or accessory product name to select 
specific examples, online documents, and support files you want 
to install for your hardware and ADEs. You can install the files 
NI-DAQ Setup recommends, as well as all or none of the 
documents associated with the devices you have selected. You can 
also include in your installation any documentation file in the list 
by manually selecting the filename.

NI-DAQ Setup displays the disk space required for the support 
files you select so that you know in advance the size of the 
installation. You can change your selections any time before 
clicking the Finish button.

b. Press Finish to install the selected support files.

5. Run Measurement & Automation Explorer to configure your device. 
Right-click on any element of the Measurement & Automation 
Explorer to navigate and view the available options.

a. Select the Devices and Interfaces option to display the National 
Instruments devices that Measurement & Automation Explorer 
automatically detects. Use this selection to configure resources 
and other physical properties of your devices and interfaces. using 
this selection, you can view attributes of one or multiple devices, 
such as serial numbers. 

b. For any products you have that are not listed, right-click on 
Devices and Interfaces, and from the list displayed, select Insert. 
A dialog box appears with a list of available National Instruments 
products. Select your products to add them to the list, then 
configure them.

Note Plug and Play devices, such as PCI, PXI, DAQCard, USB and other PnP devices, 
should appear automatically in this list if the hardware has been installed. If you 
are using a non-PnP device under Windows 98/95, you must use the Add New 
Hardware wizard to add Data Acquisition Devices. In addition to Plug and Play 
devices, you can configure SCXI and remote device access (RDA) devices.
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c. Insert virtual channels for your device, if desired. Right-click on 
Data Neighborhood and select Insert»Virtual Channel . Use the 
Virtual Channel Setup wizard to complete your virtual channel 
configuration.

d. You can set up simple operations to perform on your data. 
Right-click on Scales and select Insert»Custom Scale. Use the 
Custom Scale Setup wizard to set up the desired operations.

Your software and hardware installation and configuration are complete. 

Windows NT 4.0 Support
NI-DAQ 6.5 supports all National Instruments DAQ products in Windows 
NT 4.0. To facilitate this support, NI-DAQ 6.5 uses 16-bit integers in many 
function parameters, as compared to the 32-bit integers used in NI-DAQ 
version 4.9.0 and earlier. Therefore, if you have existing code that uses an 
old version of NI-DAQ and you want to upgrade the code to use 
NI-DAQ 6.5 with Windows NT 4.0, you need to change the appropriate 
function parameters to 16-bit integers.

Windows NT 4.0 assumes that a driver supports only one PC Card 
(PCMCIA card) at a time, but NI-DAQ 6.5 overcomes this restriction. If 
you need to use two PCMCIA DAQ cards at the same time, use 
NI-DAQ 6.5 or later.

Installing for Windows NT
To install devices for Windows NT, you must log into Windows NT as an 
administrator or as a user with administrator privileges. NI-DAQ 6.5 is 
compatible with Windows NT 4.0 and later.

ISA Devices
To use ISA Plug and Play devices (for example, AT E Series devices), you 
must install the Windows NT 4.0 ISA Plug and Play driver and your 
NI-DAQ driver software before you install your DAQ hardware. The ISA 
Plug and Play driver is not installed by default. Follow these steps to install 
the drivers:

1. Insert your Windows NT 4.0 CD.

2. Go to the \Drvlib\Pnpisa\X86  directory.

3. Right-click once on the Pnpisa.inf  file, select the Install option, 
and follow the instructions.

4. Follow the General Installation Steps section earlier in this note.

For more information about installing NI-DAQ in Windows NT, read the 
Device Configuration section in Chapter 1, Introduction to NI-DAQ, of the 
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NI-DAQ User Manual for PC Compatibles. Also, refer to the Using the 
Online Documentation Set section later in this note.

After you complete the NI-DAQ installation, you must install and configure 
your DAQ devices. You can access the NI-DAQ Readme file under 
Start»Programs»National Instruments DAQ. The help file has useful 
information on installing DAQ hardware.

Windows 98/95 Support of 16-Bit Applications
NI-DAQ 6.5 does not support 16-bit programs under Windows 98/95.

Using the Online Documentation Set
The NI-DAQ for PC Compatibles documentation set includes the 
following online help and Adobe Acrobat portable document format (PDF) 
files:

• The NI-DAQ Function Reference online help file

• The LabVIEW/DAQ online help file

• The NI-DAQ User Manual for PC Compatibles

• The NI-DAQ Function Reference Manual for PC Compatibles

• The DAQ Hardware Overview Guide

NI-DAQ Setup automatically installs the online help files and electronic 
documents that are in the NI-DAQ for PC Compatibles documentation set, 
unless you choose not to install them. 

To view the NI-DAQ function reference online help, open the Ni-daq  
directory installed on your computer, select Docs , click on Nidaqpc . The 
LabVIEW DAQ VI help will be in your LabVIEW directory.

The NI-DAQ Device help file, which is part of Measurement & 
Automation Explorer online help, is also installed. Measurement & 
Automation Explorer contains two kinds of help—help on using 
Measurement & Automation Explorer, and help on using your device and 
application. To view the help while running Measurement & Automation 
Explorer, select Help»Help Topics.

To access information about configuring your DAQ device, from the 
Contents page, click on Configure DAQ, which opens a topic called 
Introduction to DAQ configuration with the Measurement & 
Automation Explorer. This page contains links to extensive information 
on how to configure all of the available National Instruments DAQ devices.
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To view the PDF files listed above, click Start on the taskbar and select 
Start»Programs»National Instruments DAQ»Documents and then the 
document you wish to view.

NI-DAQ Setup also prompts you to install any or all of the PDF 
files—NI-DAQ 6.5 includes online versions of National Instruments 
hardware user manuals. You can read all the PDF files with the Adobe 
Acrobat Reader.

If you are using an earlier version of NI-DAQ, you may need to install 
Acrobat Reader version 3.0 or later to read the PDF files that ship with 
NI-DAQ 6.5. To install the Acrobat Reader, launch the Ar32e30.exe  file 
from the Acrobat  folder on the NI-DAQ CD.

To view the PDF documents, click Start on the taskbar and select 
Start»Programs»National Instruments DAQ»Documents and then the 
appropriate document.

Click on any entry in the table of contents to jump directly to that page. You 
can jump to major sections within each manual quickly and easily by 
clicking on the bookmarks at the left of each PDF file.

You can use Acrobat Reader to quickly find and go to every occurrence of 
any word or phrase in the document. Simply select the Tool»Find option 
and type in the key word or phrase you want to find.

When you choose the View»Go To Page option or are printing pages, you 
must use the page numbers in the lower left corner of the Acrobat window, 
not the number displayed at the bottom center of each manual page or listed 
in the contents and index. The number in the bottom center of the page is 
for printed documents only. The PDF files are electronic duplicates of the 
printed documentation. These numbers may not match those shown at the 
bottom of each manual page.

After you install your NI-DAQ software, you can access the NI-DAQ 
documentation on your software CD or diskettes. To install any online 
documents after the initial installation of NI-DAQ 6.5, reinsert your CD, 
run NI-DAQ Setup, and select the documents you want to install. 

You can assemble your own printed manual by printing either the entire 
document set or only the sections relevant to your application.

If you would like to purchase the printed NI-DAQ documentation, please 
contact National Instruments and request part number 777171-01. 
LabVIEW, ComponentWorks, and VirtualBench users do not need the 
NI-DAQ documentation. The printed documentation set includes the 
NI-DAQ User Manual for PC Compatibles and the NI-DAQ Function 



Reference Manual for PC Compatibles but does not include the DAQ 
Hardware Overview Guide. This guide is available only as a PDF file.

DAQ Support
To find sources for additional support, select Start»Programs»
National Instruments DAQ»Online DAQ Support. The National 
Instruments web page contains troubleshooting tips and frequently asked 
questions on many topics, and links to databases such as Example 
Programs and Product Manuals. This is the most up-to-date location for 
resources and help.

Use the link to the Product Manuals database to load any PDF document 
that is not available on the installer.
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